Xelion Service Disruption

Incident Report for Copaco Cloud - Statuspage

Resolved

Xelion has confirmed that the earlier service disruption has been resolved and services are operating normally again.

We will continue to monitor the service, but no further impact is expected.
Posted Jul 18, 2026 - 10:38 CEST

Investigating

We are aware of an ongoing incident affecting Xelion services. Xelion has acknowledged the issue and is currently investigating. Customers may experience service disruptions or degraded performance.

For updates from Xelion, please visit their official status page: https://status.xelionsystems.com/

We will continue to monitor the situation and provide updates when more information becomes available.
Posted Jul 17, 2026 - 17:06 CEST
This incident affected: Copaco Voice Services (Xelion nodes).