Unable to create Microsoft Tenants
Incident Report for Copaco Cloud - Statuspage
Resolved
Microsoft confirmed that the issue regarding tenant creation is solved.
You should now be able to create tenants again.
Posted Mar 28, 2024 - 17:44 CET
Identified
Currently Microsoft has some issues preventing the creation of new tenants.
This prevents new tenants to be created by the Copaco Cloud portal but also prevents us to create new tenants at Microsoft directly.
We are currently investigating this issue with Microsoft and will keep you up to date.
Posted Mar 28, 2024 - 14:43 CET
This incident affected: Workspace And Productivity (Microsoft O365).