Unable to make changes to Microsoft 365 subscriptions.
Incident Report for Copaco Cloud - Statuspage
Resolved
Microsoft has just recovered from the outage and now it's possible to make changes to Microsoft 365 subscriptions again.
Please note that the failed orders need to be placed again.
Posted Jan 10, 2024 - 13:20 CET
Investigating
At the moment, Microsoft 365 orders can fail with the error returned: "Unable to find subscription for customer "

We have identified that the issue is caused by a Microsoft Partner Center outage and are in contact with them to have this issue resolved as soon as possible. Once we have a solution or ETA for recovery, we will update this message.
Posted Jan 10, 2024 - 10:27 CET
This incident affected: Copaco Portals (Copaco Cloud Management Portal) and Workspace And Productivity (Microsoft O365).