Platform performance has been restored and the Copaco Cloud Management Portal should now be responding normally again.
The issue related to incorrect “Expired” subscription statuses is still being addressed. Work is ongoing, and further updates will follow as soon as more information becomes available.
Posted Mar 02, 2026 - 14:19 CET
Update
Work on resolving the underlying issue is still ongoing. At this moment, there is no estimated time of resolution available.
Please be assured that this incident has our highest priority, and our development team is continuing to work diligently to restore full functionality as soon as possible.
Further updates will follow as more information becomes available.
Posted Mar 02, 2026 - 13:00 CET
Update
We have confirmed that the “Expired” subscription status and the slowness of the Copaco Cloud Management Portal are related to the same underlying issue.
We expect the subscription status display to be corrected during the afternoon. The platform slowness is still being actively worked on by our development team.
Further updates will follow as more information becomes available.
Posted Mar 02, 2026 - 10:42 CET
Identified
We are currently experiencing slow performance in the Copaco Cloud Management Portal. In some cases, this may result in errors when loading customers.
Our development team is actively working to resolve this issue as quickly as possible. We will provide further updates as soon as more information is available.
Posted Mar 02, 2026 - 09:56 CET
Investigating
We have identified an issue in the Copaco Cloud Management Portal where several Microsoft subscriptions are incorrectly shown as “Expired.” After investigation, we confirmed that these subscriptions are fully active and valid at Microsoft. This is purely a visual display issue within the portal. There is no impact on the actual subscription status, functionality, or billing.
What We Are Doing Our technical team is actively working to correct the visual anomaly and restore accurate subscription statuses within the portal.
What You Need to Know - Your Microsoft subscriptions remain active. - No action is required from your side. - We will update this page as soon as the issue is resolved.
Next Update A new update will be posted as soon as the fix is deployed or more information becomes available.
Posted Mar 02, 2026 - 09:22 CET
This incident affects: Copaco Portals (Copaco Cloud Management Portal).