The needed changes have been made and the Veeam Backup for Microsoft 365 environment is completely back up.
Posted May 22, 2026 - 15:56 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 22, 2026 - 14:01 CEST
Scheduled
Currently we're investigating a back-up performance issue that is affecting some of our customers workloads together with Veeam support.
For alleviation we need to make a configuration change to the Veeam Backup for Microsoft 365 environment and this requires short downtime of the environment.
Currently running back-up jobs will be stopped and will resume as per their normal interval after the maintenance window is completed.