Get email notifications whenever Copaco Cloud - Statuspage creates, updates or resolves an incident.
Get text message notifications whenever Copaco Cloud - Statuspage creates or resolves an incident.
Get webhook notifications whenever Copaco Cloud - Statuspage creates an incident, updates an incident, resolves an incident or changes a component status.
We have received confirmation that the Microsoft Partner Center API service degradation has been fully resolved.
Posted Oct 10, 2025 - 10:02 CEST
Identified
We are experiencing a service degradation affecting Microsoft order provisioning due to issues with Microsoft Partner Center APIs
Some order submissions are experiencing significant delays or failures, with orders showing either "Provisioning Started" or "Provisioning Failed" status.
Microsoft has confirmed the issue and is working towards the resolution.
Posted Oct 09, 2025 - 11:51 CEST
This incident affected: Workspace And Productivity (Microsoft O365).