Following a monitoring period, we can confirm that the issue has been fully resolved.
Posted Jun 23, 2026 - 10:41 CEST
Monitoring
Xelion has confirmed that the issue has been resolved and calling functionality is working as expected again. We will continue to monitor the situation closely.
Posted Jun 23, 2026 - 10:21 CEST
Identified
Customers on the XEL02 environment are currently unable to make or receive phone calls. The issue has been identified and is known to Xelion. Their teams are actively working on a resolution.
Posted Jun 23, 2026 - 09:36 CEST
This incident affected: Copaco Voice Services (Xelion nodes).