The issue affecting Microsoft order provisioning has been resolved and order processing is operating normally again.
If you have submitted an order that failed during the incident, please resubmit the order. Failed requests will not be processed automatically and require a new submission.
Thank you for your patience while we worked with the relevant parties to resolve this issue. We apologize for any inconvenience caused.
Posted Sep 04, 2026 - 17:04 CEST
Investigating
We are currently experiencing an issue affecting Microsoft order provisioning. Orders for Microsoft subscriptions may fail to process and return an error similar to:
"Authentication to MS Partner Center failed. Please retry your order."
The issue is currently being investigated. Until further notice, we do not recommend placing new Microsoft orders or resubmitting failed orders. Repeated submission attempts may result in duplicate orders being processed once the issue is resolved. To prevent unintended duplicate provisioning and billing, we advise waiting until a resolution has been communicated.
We are actively monitoring the situation and working with the relevant parties to resolve the issue as quickly as possible. Further updates will be provided as soon as additional information becomes available.
We apologize for the inconvenience and appreciate your patience.
Posted Sep 04, 2026 - 16:44 CEST
This incident affected: Workspace And Productivity (Microsoft O365).