Service Disruption: Microsoft orders may remain stuck in a “Provisioning Started” state

Incident Report for Copaco Cloud - Statuspage

Resolved

The issue has been resolved and services are operating as expected.
Posted May 29, 2026 - 15:47 CEST

Monitoring

We are seeing positive progress. New orders are no longer getting stuck, and previously affected orders in a pending state have now been successfully completed. We will continue to monitor the situation.
Posted May 29, 2026 - 15:05 CEST

Identified

Microsoft has confirmed an active outage and indicated that partial recovery is currently underway.
Posted May 29, 2026 - 10:14 CEST

Investigating

Microsoft orders created after Friday, 29 May 2026 at 05:53 UTC may remain stuck in a “Provisioning Started” state and may not complete as expected.

Initial investigation indicates that the root cause originates from Microsoft.

We are actively monitoring the situation and are working closely with Microsoft to resolve the issue as quickly as possible.

In the meantime, we kindly request that you refrain from placing duplicate orders for the same subscriptions, as this may result in unintended duplications once the issue has been resolved.
Posted May 29, 2026 - 10:01 CEST
This incident affected: Workspace And Productivity (Microsoft O365).