Billing run delayed

Incident Report for Copaco Cloud - Statuspage

Resolved

The issue is resolved. All monthly invoices are processed. If you still have an issue, please contact support (support@copaco.cloud)
Posted Jun 01, 2023 - 11:55 CEST

Investigating

Your monthly Copaco Cloud invoice is delayed. We’re experiencing a delay in creating the PDF invoices. Copaco and CloudBlue are collaborating to resolve the issue. We’ll update here on Status Page as soon as we know more. The invoice will be send automatically. Our apologies for any inconvenience caused.
Posted Jun 01, 2023 - 08:09 CEST
This incident affected: Copaco Portals (Copaco Cloud Management Portal).