Delays in Microsoft Order and Subscription Processing

Incident Report for Copaco Cloud - Statuspage

Identified

The issue affecting the Copaco Cloud Partner Portal is still ongoing. Our earlier update reported a recovery, but the platform remains slow and processing is inconsistent: some Microsoft orders and license changes complete normally, while others time out or remain at "provision started" without completing.

The cause has been identified as degraded performance in the order processing chain, and work to restore normal performance is ongoing.

What this means:
- Pages in the portal may load slowly, and orders and license changes may take longer than usual
- An order that remains at "provision started" will not complete on its own
- Please do not resubmit an order or license change that timed out or is still in progress. Resubmitting may result in duplicate provisioning and billing.

We are actively working on a resolution together with the relevant parties and will provide an update as soon as more information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 10, 2026 - 10:50 CEST

Monitoring

The issue affecting the processing of Microsoft orders and subscription changes is expected to be resolved. It was caused by a short period of degraded performance in the order processing chain, and orders and license changes are being processed again.

We are keeping this incident open while we monitor the platform to confirm that processing remains stable.

If you have submitted an order or license change that timed out or remained at "provision started" during the incident, please verify the current state of the subscription before submitting it again. Requests that failed are not processed automatically and require a new submission, while resubmitting a request that did go through may result in duplicate provisioning and billing.

We will provide a further update once we have confirmed that the issue is fully resolved.
Posted Sep 10, 2026 - 10:10 CEST

Investigating

We are currently experiencing an issue affecting the processing of Microsoft orders and subscription changes in the Copaco Cloud Partner Portal, which started at approximately 09:15 CEST.

Users may experience:
- Slow loading of catalog and order pages, and slow processing of changes to the order (for example switching a billing term)
- Timeout errors when increasing or decreasing the number of licenses
- Subscription changes that remain at "provision started" and do not complete
- Upgrade options (partial upgrade) not loading for any tenant
- A generic "Oeps" error, or a message about the tenant not being linked, when adding an item to the cart

Existing subscriptions and active services are not affected. The issue is limited to placing new orders and modifying existing subscriptions.

We are aware of the issue and are actively working on a resolution together with the relevant parties. We will provide an update as soon as more information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 10, 2026 - 09:52 CEST
This incident affects: Workspace And Productivity (Microsoft O365).